Errors and delays caused by a sudden increased load
Incident Report for elastic.io GmbH
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 14, 2018 - 17:47 CET
Monitoring
We have cleaned the old execution statistics and have brought back some of the suspended integration flows. The platform is operational. We will be monitoring the situation for the next 15 minutes to make sure that all the services are in order.
Posted 11 months ago. Nov 14, 2018 - 17:26 CET
Identified
We have identified the root cause of the problem with our past integration flow statistics records. Past, unused records had a grace period before they got deleted. However, with an unexpected load on our system, the rate at which it stored new records was higher than expected. We were getting closer to the assigned capacity.

We had no choice, but to remove some older executions as a temporary measure. At the moment we are increasing the capacity by dedicating more resources.

You might experience a situation when visiting the execution page you would not find the page. This is a temporary situation and is connected with the load of the system. We are sorry for this inconvenience.
Posted 11 months ago. Nov 14, 2018 - 17:09 CET
Update
We are continuing to investigate this issue.
Posted 11 months ago. Nov 14, 2018 - 16:40 CET
Investigating
We are investigating the situation with several workspaces where the UI is not loading due to the increased amount of errors and a sudden load increase.
Posted 11 months ago. Nov 14, 2018 - 16:15 CET
This incident affected: elastic.io app.