Back to overview
Degraded

Slow Webhook transactions and Maester requests

Dec 30 at 07:30am CET
Affected services
EU cluster API
EU cluster WebHook
EU cluster Realtime

Resolved
Dec 30 at 08:30am CET

Slow Webhook transactions and Maester requests

Issue

Significantly increased platform load was experienced from 23:40 CET on 29.12.2023. Speed of message processing was affected. The condition remained stable, but slow until sporadic time-outs began to occur for Webhook and Maester requests. At 07:30 CET on 30.12.2022 webhook and Maester requests began to fail.

Status/Resolution

The issue was resolved at 08:14 CET on 30.12.2022 by scaling system services to cope with the increased load. No data loss has been identified.

Prevention/Corrective actions

More refined monitoring is being implemented to provide more advanced warning of load issues. The services concerned have been expanded to accommodate increased load.

We apologise sincerely for any inconvenience and thank you for your trust in elastic.io

Updated
Dec 30 at 08:14am CET

The issue was resolved by scaling platform caching services to increase processing speed.

Created
Dec 30 at 07:30am CET

Webhook executions and requests to our storage service Maester were timing out due to slow responses.